Archive

Articles taggués ‘jailbreak 3.5’

Comment jouer à GT5 et NFS HP sur PS3 Jailbreaké 3.41

07/01/2011 2 commentaires

PS3 jailbreak 3.50 spoof

Ca y est c’est fait depuis quelques jours (et j’étais un peu passé à côté), il est maintenant possible de jouer à GT5 et NFS Hot Poursuite sur une PS3 jailbreaké en 3.41.

C’est un membre du forum psx-scene qui a mis ça au point. Il a réussi à patcher les fichiers eboot.bin des jeux nécessitant le firmware 3.50.

On trouve déjà les jeux patché en téléchargement. La manipulation reste tout de même assez hasardeuse et ne fonctionne pas sur tous les jeux. Mais elle a le mérite d’exister et de fonctionner pour GT5 et NFS HP c’est le plus important non ?Razz

Attention, il va falloir utiliser un firmware sur la clé jailbreak qui supporte le spoof 3.5 pour y jouer (voir ce tuto pour la E3 Card Reader)

Comme j’ai rien compris à ce qu’il fallait faire pour patcher, je vous met directement les eboot.bin patchés^^

Patch Eboot.bin 3.50 GT5 ici

Patch NFS HP Eboot.bin 3.50 ici

Patch SplatterHouse Eboot.bin 3.50 ici

Patch Undead Nigthmare Eboot.bin 3.50 ici

Patch Majin The Forsaken Kingdom Eboot.bin 3.50 ici

Patch Harry potter Eboot.bin 3.50 ici

D’autres jeux sont ajoutés

Mais pour ceux qui veulent vraiment le faire eux même, voici la procédure (en anglais):

  1. Open EBOOT.BIN in a hex editor of your preference.
  2. In EBOOT.BIN, look at the SELF control info, if you see anything resembling the game titleid, it’s an NPDRM SELF and this guide won’t work, give up.
  3. Use readself on EBOOT.BIN to get information about the encrypted metadata sections.
  4. unself EBOOT.BIN eboot.elf
  5. Open eboot.elf in a hex editor of your preference.
  6. In eboot.elf, go to every encrypted metadata section (now decrypted), copy its data, and replace the encrypted data in EBOOT.BIN.
  7. In EBOOT.BIN, change SELF header to indicate it’s FSELF.
  8. In EBOOT.BIN, change SELF section headers that are marked as encrypted to say they are not encrypted.
  9. If the game is a newer SDK version (like GT5, which is 3.50), in EBOOT.BIN, find the .sys_proc_param segment and change the SDK version to something earlier, such as 3.41. This will probably cause crashes in games that actually use newer SDK features that are not available in earlier SDK versions.
  10. Save EBOOT.BIN
  11. Cross fingers, run game, hope it works <== voilà pourquoi je disais que c’est hasardeux Wink

A+

Get Adobe Flash playerPlugin by wpburn.com wordpress themes